Community Forum

User info

Welcome, Guest! Please login or register.


You are here » Community Forum » New Forum Features » Requests for Scripts


Requests for Scripts

Posts 1 to 30 of 32

1

Alex_63 wrote:

This topic is for users' requests for creating or modifying scripts. Please write here if you have any questions or requests for JavaScript extensions.

0

2

Wins
http://sk.uploads.im/LaDK3.png

Code:
[img]URL of Image[/img]

Last edited by kami (2017-04-09 04:23:31)

0

3

C3La-NS wrote:

Custom Colors for reply-box (by Romych)
This Javascript extension allows you to pick up any color you want.
How it works:

Code:

Installation: Administration --> Options --> HTML footer area.


its not working but it shows custom color option  in reply -box when i click on it no function . there is no extra color option appear

0

4

study.mybb.online
May I have a link of your forum, I'll try to fix it.

0

5

Alex_63
Is it possible ? or are there certain codes that can be used to display all categories and topics on the .. /pages ? (including topic views / similar function what we see now on the home page)....

0

6

Alex_63 wrote:

SUB-FORUMS with Auto-Setting

Just reporting
I have tried several times ...i have been able to create some sub forums, but i find problems like admin function to be disturbed, click navigation sometimes not working perfectly.....

0

7

kami wrote:

Is it possible ? or are there certain codes that can be used to display all categories and topics on the .. /pages ? (including topic views / similar function what we see now on the home page)....

Don't quite understand the essence of the question. Do you want to show the content of categories (from the index page) on your page that created in Admin-Pages?

kami wrote:

I have tried several times ...i have been able to create some sub forums, but i find problems like admin function to be disturbed, click navigation sometimes not working perfectly.....

Please explain, what does it mean "admin functions are disturbed"? There were some problems in original (Russian) version, but I've fixed them several months ago. Which functions stop working?

0

8

Alex_63 wrote:

kami wrote:
Please explain, what does it mean "admin functions are disturbed"? There were some problems in original (Russian) version, but I've fixed them several months ago. Which functions stop working?

cant click the Save button,

+1

9

Alex_63 wrote:

Don't quite understand the essence of the question. Do you want to show the content of categories (from the index page) on your page that created in Admin-Pages?

Want to make ../pages/examplewelcome as index page but unfortunately not available the function...

so The solution:
the admin forum hides all categories & topics on the index page.... but all users still can find the categores and topics in /pages/forum (new page that created via Admin-Pages)

->or if possible...  domain.com/forum

Last edited by kami (2017-05-24 08:45:39)

0

10

kami wrote:

cant click the Save button,

On which pages in admin-panel is the issue noticed?

kami wrote:

so The solution:
the admin forum hides all categories & topics on the index page.... but all users still can find the categores and topics in /pages/forum (new page that created via Admin-Pages)

I will try to do this through a script, please wait for my solution

0

11

Alex_63 wrote:

On which pages in admin-panel is the issue noticed?

/admin_options.php
/admin_style.php
now cant Click add sub forum

Alex_63 wrote:

I will try to do this through a script, please wait for my solution

Waiting Thank you

Last edited by kami (2017-05-25 08:36:32)

0

12

kami

kami wrote:

/admin_options.php
/admin_style.php
now cant Click add sub forum

Please give me(in PM) a nickname and pass of account with access to admin panel, I'll go to your forum and check

0

13

kami wrote:

Want to make ../pages/examplewelcome as index page but unfortunately not available the function...

1. Create a page with content that will be shown on the index page instead of categories
2. Add this script to HTML header

<style id=HidMain>#pun-index .main{display:none}</style>
<script type="text/javascript">
$(document).pun_mainReady(function(){
var LNKportal = '/pages/test'; // Link to page with content(to load)

$('#navindex').after(' <li id="navportal"><a href="/">Portal</a></li>')
.find('a')[0].href += String.fromCharCode(173)+'forum';function tst(){$('#HidMain').remove()};
if($('#pun-index').length==0) return; var a='<div id="pun-main" '+'class="main pages">';
if(document.URL.indexOf('/%C2%ADforum')!=-1){tst();return}
var s = a+($.ajax({url:LNKportal,async:false,cache:true}).responseText
.split(a)[1].split('<script type="text/javascript">$(document).trigger')[0])
.replace(/<(\/?)h1>/gim,'<$1h2>');$('#pun-main').remove();document.write(s);tst()});
</script>

And put the link to you page instead of red.

0

14

Alex_63 wrote:

And put the link to you page instead of red.

This script is very useful and can be used without any errors. Thank You

Alex_63 wrote:

Please give me(in PM) a nickname and pass of account with access to admin panel, I'll go to your forum and check.

I'm just training to create sub forums, maybe one day I need this script ... . PM you

Last edited by kami (2017-05-25 22:08:17)

+1

15

kami
The problem is created by scripts that are set by the partner service tcihosting.cf, they are incorrect and are breaking the events on the page, so the buttons in the admin panel doesn't work.
These scripts (in red):

<script type="text/javascript">
</script> <script src="http://wcoders.wapsite.me/WCF+Projects/bbcode.js"></script>
<center><div id="powered" style="display:none;"><br/><br/> <div width="50%" align="center" style="border:8px dashed brown;" /*This our copyright link you are not to remove it doing so will prevent us from answering any complaints you may have*/ ><table align="center" width="100%"
border="1px"><tr><td align="center" bgcolor="gray"><b style="color:cyan">Powered By <a href="http://tcihosting.gq">Tcihostingô</a> 2016 - 2017</b></td></table></div></div></center><style>#powered {
              position: absolute;
              top: ;
              bottom:0px;
              }@import url(http://css.blogponsel.mobi/responsive.css); </style> <script src="http://wcoders.wapsite.me/WCF+Projects/wcodes.js"></script>  <style>@import url(http://wcoders.wapsite.me/WCF+Projects/wcf-styler.css);</style> <script src="http://wcoders.wapsite.me/WCF+Projects/wcf-sc.js"></script><script> document.addEventListener('DOMContentLoaded', function(){
      if (window.location.href.indexOf('admin_index.php') != -1) {
        document.getElementById('pun-admain1').style.display='none';
      }
    }); </script>

+1

16

Thank you for the information Alex_63, i will try to create sub forums in different partner and will report if found error until i am good at this sub forum script... thank u very much

0

17

@kami the first script adds more bbcodes to the forum but i will remove them if its causing problems

0

18

done removed the script if you want to have the bbcodes enabled then check this link http://wcoders.cf/viewtopic.php?id=71

0

19

Alex_63 wrote:

<style id=HidMain>#pun-index .main{display:none}</style>
    <script type="text/javascript">
    $(document).pun_mainReady(function(){
    var LNKportal = '/pages/test'; // Link to page with content(to load)

    $('#navindex').after(' <li id="navportal"><a href="/">Portal</a></li>')
    .find('a')[0].href += String.fromCharCode(173)+'forum';function tst(){$('#HidMain').remove()};
    if($('#pun-index').length==0) return; var a='<div id="pun-main" '+'class="main pages">';
    if(document.URL.indexOf('/%C2%ADforum')!=-1){tst();return}
    var s = a+($.ajax({url:LNKportal,async:false,cache:true}).responseText
    .split(a)[1].split('<script type="text/javascript">$(document).trigger')[0])
    .replace(/<(\/?)h1>/gim,'<$1h2>');$('#pun-main').remove();document.write(s);tst()});
    </script>
.

What code should be added to use icon image instead of using the text: Portal link in navigation when accessed via smartphone?

0

20

kami
Add this to HTML header (the text that selected in red - change to your link to image)

<style type="text/css">
@media screen and (max-width:540px ){
.punbb #pun-navlinks #navportal{
  display:inline-block!important;
}
.punbb #pun-navlinks #navportal >a{
  background-image:url(IMAGE LINK)!important;
  background-position:center center!important;
}
}
</style>

0

21

not working well... -> Image and text (both visible via mobiling)

+1

22

kami
Try changing the script:

<style id=HidMain>#pun-index .main{display:none}</style>
<script type="text/javascript">
$(document).pun_mainReady(function(){
var LNKportal = '/pages/test'; // Link to page with content(to load)

$('#navindex').after(' <li id="navportal"><span><a href="/">Portal</a></span></li>')
.find('a')[0].href += String.fromCharCode(173)+'forum';function tst(){$('#HidMain').remove()};
if($('#pun-index').length==0) return; var a='<div id="pun-main" '+'class="main pages">';
if(document.URL.indexOf('/%C2%ADforum')!=-1){tst();return}
var s = a+($.ajax({url:LNKportal,async:false,cache:true}).responseText
.split(a)[1].split('<script type="text/javascript">$(document).trigger')[0])
.replace(/<(\/?)h1>/gim,'<$1h2>');$('#pun-main').remove();document.write(s);tst()});
</script>

0

23

Already tried:

The effect:
The IMAGE LINK from CSS below is not displayed and the text is still visible

.punbb #pun-navlinks #navportal >a{
  background-image:url(IMAGE LINK)!important;
  background-position:center center!important;

0

24

kami
Sorry, there is some incorrectness in the code. Try this version:

<style id=HidMain>#pun-index .main{display:none}</style>
<script type="text/javascript">
$(document).pun_mainReady(function(){
var LNKportal = '/pages/test'; // Link to page with content(to load)

$('#navindex').after(' <li id="navportal"><a href="/"><span>Portal<span></a></span></li>')
.find('a')[0].href += String.fromCharCode(173)+'forum';function tst(){$('#HidMain').remove()};
if($('#pun-index').length==0) return; var a='<div id="pun-main" '+'class="main pages">';
if(document.URL.indexOf('/%C2%ADforum')!=-1){tst();return}
var s = a+($.ajax({url:LNKportal,async:false,cache:true}).responseText
.split(a)[1].split('<script type="text/javascript">$(document).trigger')[0])
.replace(/<(\/?)h1>/gim,'<$1h2>');$('#pun-main').remove();document.write(s);tst()});
</script>

And add this (selected in blue) to the CSS code for mobile version:

<style type="text/css">
@media screen and (max-width:540px ){
.punbb #pun-navlinks #navportal{
  display:inline-block!important;
}
.punbb #pun-navlinks #navportal >a{
  background-image:url(http://s7.uploads.ru/EUgW1.gif)!important;
  background-position:center center!important;
}
}
#navportal a span {
  font-size:1em!important;
}

</style>

+1

25

Now Working ! thanks

+1

26

http://sl.uploads.im/KPp98.png
Please guide me how to add a twitter small icon for user login / register
or if possible you are willing to add this feature in the mybb login/register system  just like some social sites that have been added
<a class="social social-twitter" href="/connect.php?provider=twitter"></a>

0

27

kami
Unfortunately I know no way to add authorization with Twitter to forums. But I've written to Admin of service about your request, maybe he'll do something for this.

+1

28

kami
Looked at code on your forum (in HTML footer) - the code selected in red is not required because there is no scripts inside these selectors:

$("#pun-ulinks script").remove();/*Removing the scripts from the Post Form*/
$("#pun-pagelinks script").remove();/*Removing the scripts from the Post Form*/
$("#pun-searchtopics script").remove();/*Removing the scripts from the Post Form*/
$("#pun-stats script").remove();/*Removing the scripts from the Post Form*/
$("#navindex script").remove();/*Removing the scripts from the Post Form*/
$("#pun-navlinks script").remove();/*Removing the scripts from the Post Form*/
$("#pun-status script").remove();/*Removing the scripts from the Post Form*/
$("#pun-navlinks script").remove();/*Removing the scripts from the Post Form*/
$("#onlinelist script").remove();/*Removing the scripts from the Post Form*/
$("#pun-userlist script").remove();/*kamu*/
$("#viewprofile script").remove();/*suka*/
$("#profilenav script").remove();/*saya*/
$("#profile script").remove();/*buktikan*/
$("#pun-viewforum script").remove();/*dong*/
$("#pun-index  script").remove();/*yuk*/
$("#pun-viewtopic script").remove();/*baca surat cinta*/

$("#post script").remove();/*ku*/

Only this code is needed:

$("#post script").remove();

because in the post form there is some JavaScript code that should be removed before changing words in the form.

+1

29

Thank you
i got problem with this script..

see

$(document).ready(function(){
$('#pun-viewtopic div.post').each(function(){
var purl = $(this).find('.pl-email:first a').attr('href');
var pem = $(this).find('.pl-email:last a').attr('href');
var pls = purl.slice(purl.indexOf('id=')+3);var pweb = $(this).find(".post-links ul li.pl-website a");
var pwu = pweb.attr("href");
var sumb = String.fromCharCode(9660);
$(this).find("div.post-author .pa-author a").after(" <span style='cursor:pointer;' class='vprofo open'>"+sumb+"</span><div class='viewp' style='color: rgb(153, 153, 153);display: block;position: absolute;margin-left: 30px!important;width: auto;padding: 8px;background: #fff; border: 1px solid #cecece;'>ē <a href='"+purl+"'>Profile</a><br />ē <a href='/messages.php?action=new&uid="+pls+"'>PM</a><br>ē <a href='"+pem+"'>Email</a><fweb><br>ē <a href='"+pwu+"'>Website</a></fweb></div>");
if(pweb.length){}else {$(this).find("fweb").replaceWith(" ");}
$(".viewp, .pl-email, .pl-website").hide();
$(this).find("div.post-author .pa-author .vprofo").click(function () {
$(this).toggleClass("open").toggleClass("close").next().toggle()});});});

http://sl.uploads.im/t/9F2Bv.png

if I added the code below
$("#pun-viewtopic script").remove();/*dddd*/
the problem will solved...

Also some scripts contradict one another and cause a double effect ,,, but I have to reset, to find out which of the script is still problematic and conflicting

Added after 15 hours 29 minutes 5 seconds:
All coused by the wrong univerchange below (made a double effect on some scripts / Please give me the exact univerchange for Profile View Or maybe any other script that can translate the profile view)
http://sj.uploads.im/t/qacNY.png

see

Univer—hange("dont know","minutes","....");
Univer—hange("dont know","minute","....");
Univer—hange("dont know","Today",".......");
Univer—hange("dont know","Yesterday",".......");
Univer—hange("dont know","Real name","......");
Univer—hange("dont know","Sex","........");
Univer—hange("dont know","Female","........");
Univer—hange("dont know","Male",".....");
Univer—hange("dont know","Location",".......");
Univer—hange("dont know","Registered","..........");
Univer—hange("dont know","Num invites",".....");
Univer—hange("dont know","Total time","..");
Univer—hange("dont know","days","......");
Univer—hange("dont know","hour",".........");
Univer—hange("dont know","day",".........");
Univer—hange("dont know","hours","......");
Univer—hange("dont know","Positive",".....");
Univer—hange("dont know","Respect",".......");
Univer—hange("dont know","Interests","............a");
Univer—hange("dont know","About me",".......");
Univer—hange("dont know","Posts","...........");
Univer—hange("dont know","Show all posts",".......");
Univer—hange("dont know","Last post","........");
Univer—hange("dont know","Never","........");
Univer—hange("dont know","Last visit","..............");

See Profile with the Wrong UniverChange

Last edited by kami (2017-06-30 10:42:20)

0

30

kami wrote:

Please give me the exact univerchange for Profile View

Try to replace "dont know" in your example to "#profile-right li"

kami wrote:

if I added the code below
$("#pun-viewtopic script").remove();/*dddd*/
the problem will solved...

Try this code:

$(".punbb script").remove();

+1

Related topics


You are here » Community Forum » New Forum Features » Requests for Scripts